Thursday, May 27, 2010

strange apache error

apache failed to start with an error:

[Thu May 27 13:41:29 2010] [crit] (28)No space left on device: mod_rewrite: could not create rewrite_log_lock
Configuration Failed

Carlos Rivero has a solution using perl.

Here is what I used, as somebody suggested in the comments to the post linked above:

ipcs -s | grep emilper | awk ' { print $2 } ' | xargs ipcrm sem

then restarted the server

Monday, May 24, 2010

installing padre 0.62 on debian sid

Got an unexpected "bank holiday", so I am playing.

Padre installs nicely on Debian Sid when using CPAN on 2010-05-24 ... I wonder if I am doing something wrong :P ... or maybe Padre is getting closer to being ready for prime-time.

Plugins that installed cleanly:

  • Padre::Plugin::PAR

  • Padre::Plugin::XS

  • Padre::Plugin::Encrypt

  • Acme::Padre::PlayCode

  • Padre::Plugin::Nopaste

  • Padre::Plugin::DataWalker

  • Padre::Plugin::HTML

  • Padre::Plugin::HTMLExport

  • Padre::Plugin::JavaScript

  • Padre::Plugin::Kate

  • Padre::Plugin::CSS

  • Padre::Plugin::Ecliptic

  • Padre::Plugin::SpellCheck

  • Padre::Plugin::PHP

  • Padre::Plugin::ViewInBrowser

  • Padre::Plugin::PerlCritic

  • Padre::Plugin::Debugger

  • Padre::Plugin::Encode

  • Padre::Plugin::Alarm

  • Padre::Plugin::Swarm

  • Padre::Plugin::ClassSniff

Plugins that fail tests:

  • Padre::Plugin::Shell::Base

  • Padre::Plugin::CommandLine

  • Padre::Plugin::InstallPARDist

  • Padre::Plugin::Vi

  • Padre::Plugin::Template

  • Padre::Plugin::Filter

perl editors


When using subclipse with Aptana Studio or Eclipse, it will complain about missing "libsvnjavahl-1". On Debian, the package libsvn-java needs to be installed. After that /usr/share/java/svn-javahl.jar needs to be added as "external jar" to the JRE in use.

EPIC should install with no trouble.

In Eclipse I am giving a try to QuantumDB Eclipse Plugin for database browsing: it can be installed easily from the Aptana plugin manager.

Eclipse is a pain when working on remote files (even with ssfs) if the link is not lightning fast, so other editors I use are Komodo Edit (kind of an unofficial standard at work), Emacs (at home, always come back to it after exploring alternatives), or Kate.

Monday, May 17, 2010

daemontools install on centos 5.4

after getting this error:

/usr/bin/ld: errno: TLS definition in /lib/ section .tbss mismatches non-TLS reference in envdir.o 

need to edit

add this:

-include /usr/include/errno.h

... via Installing Bernstein’s daemontools on CentOS 5