Thursday, July 1, 2010

"amusing" @INC trouble

got into a bit of panic today:

$ perl -e 'use LWP'
Global symbol "%Config" requires explicit package name at ...

This happened when running anything that used perl, and this error I have not seen before.

Asking around and googling resulted in one conclusion: core is busted, Perl is damaged, must reinstall. Lucky for me I realized there was a in the folder I was in at the time, and './' was in pole position in my @INC.